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from Intalio BPMS
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Accessing MySQL from Intalio BPMS

Author: Brian Reynolds, Risaris Ltd



1 Introduction
In this tutorial we will show you how to use an Intalio BPMS process to access MySQL via the SOA
Gateway.

2 Prerequisites
It is assumed that you are running the 4 components, MySQL, Intalio|BPMS Designer, Intalio| BPMS
server, and the SOA Gateway on Windows.

Intalio| BPMS 5.2 is the minimum version required. Some basic knowledge of Intalio| BPMS is also
required.

It is assumed you already have a SOA Gateway server and Control Centre installed. See here for
more info about installing the SOA Gateway.

3 Setup

If you have not already done so, install the Intalio | BPMS Designer and Server.

You will also need a MySQL database. The Open Source version (known as the MySQL Community
Server) can be freely downloaded from the MySQL website. See this link for download, and here to
step you through the installation and configuration.

3.1 Populate MySQL Database
Now that you’ve got MySQL installed and config
demo data. For this we use the RisarisBank sample. This is available here .

Save thi\temp\RileartiosBa&nk. sqgl”
9 Connect to the MySQL Server using the mysgl command.
E.g shell> mysql Cu root Cp

This command connects to the server using the MySQL root account to make sure that
you'll have permission to create the RisarisBank  database. The - p option tells mysql
to prompt you for the root password. Enter the password when prompted. (Remember
that the MySQL root account is not the same as the operating system root account
and probably will have a different password.)

1 Create the RisarisBank  database.
mysql> CREATE DATABASE RisarisBank;
mysql> use RisarisBank;
9 Load the contents of RisarisBank.sql into the RisarisBank database. E.g.

mysql> SOURCE c:\Temp\RisarisBank.sql
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http://www.risaris.com/documentation/v411/installation/index.htm
http://dev.mysql.com/downloads/mysql/5.0.html#downloads
http://dev.mysql.com/doc/refman/5.0/en/windows-installation.html
http://risaris.com/samples/RisarisBank.sql

9 After the SOURCE command finishes, you can view your new tables.
mysql> SHOW TABLES;
mysql> DESCRIBE CustomerInformation;
mysql> DESCRIBE Branch;
SO0 X

9 Optionally, you can disable the requirement for a userid and password. Enter the
following statements to do this:

mysql> grant all on RisarisBank.* to root@Ilocalhost;
mysql> flush privileges;

Note
If you wish to revoke this later enter the following statements:

mysql>revoke all privileges, grant option from root@Iocalhost;
mysql>flush privileges;

3.2 Setup ODBC Access
The final thing to do with your MySQL Database is to set up an ODBC DSN which will be used by
the SOA Gateway to access this database.

Click Start, Control Panel, Administrative Tools, Data Sources (ODBC)

Fromt he resulting screen, choose the “System DSN
Click Add
From the 1 1i st of data source drivers, sel ect “

If you do not see this driver in the list, you need to install the MySQL Connector. See here for
more information. We recommend installing v3.51.

Click Finish, and a window will appear allowing you to enter the DSN information. Add the
following:

Data Source Name: RisarisBank

Description: The Risaris Bank Sample in MySQL
Server: localhost

User: root

Password: *** your MySQL root password ***

Database: RisarisBank (select from the drop down list)
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http://www.mysql.com/products/connector/odbc/

nl:unnectur,.-"DDBE 3.51.20 - Add Data Source Mame

™
Connector/0DBC Erought to vou by the database el
VI
Login | Connect Cptions I Advanced I
Database
Drata Source Mame |RisarisBank
Description |The Risaris Bank Sample in My3S0L The database to be current upon connect.
Server I localhost
Optional Yes
Default [none]
ser Iru:u:ut
Password | R
Datahase I RisarisBank] ;I
Test Diagnostics == | (0] 3 Zancel Help
All other options can be left as-is. Click OK.
4 Discovery
At t hi s stavysldytabase wthesomg sarhpled at a i n it . I n t

you how to create web services from each of the MySQL tables. These web services can be used in

Intalio BPMS Web Service queries to give you direct real-time access to your MySQL Data.

4.1 Web Service Creation using SOA Gateway
Start your SOA Gateway Control Centre. See here for an introduction to the Control Centre.

In your servers view, right click the entry which represents your local SOA Gateway Server. Select

“Create New Web Servi
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http://www.risaris.com/documentation/v411/gettingstarted/intro.htm

e —_
.. SDA Gateway Servers (. Eq fit 50A Gateway Sery

«> ¥ ¥ | WebServices I[)ata'lu

Name | M... | ASY | Tracing | il L| Driver
ALY Server Y  OFF/7T

= Lm:al Server
2/05 Server t:gh Refresh Configuration

Suspend Server

2] set Credentials For Server

VAJ Save current Configuration ko server File
& | Import Configuration into Control Center

& Export Configuration from Control Center

5 Export WebService Definition(s) to server

¥ Remove Server definition

&5 Add new S04 Gakeway conneckion

=

From the next dialog, choose “MySQL Driver?”
see how to create one here.

.5!]A Gateway - WebService creation |

This wizard will guide you through the process
of generating new WebServices.

Select the source of data [YFESTR T - =
Discovery timeout fsecunlgu

Mexkt > | Done |

Click Next.

The next screen gives you the ability to add information about your DSN
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http://www.risaris.com/documentation/v411/admin/ccserver.htm#mod_drivers

!SDA Gateway WebService Creation {mysql) Ed

Step 1 - select input

0ODBC Dsn

Pattern

Max.entries to list I

—Specify ODBC descriptors & option(s)

IRisarisBank

Userld / Passwurdlruut

— Options for generated WebSeryice name

-

Advanced Options

Enter the above information and click Discover.

Discover Cancel

The wizard will display all the tables it finds at this (RisarisBank) DSN.

Click *

Sel ect

Al ",

and click “I mpo

The wizard will create web services from each one of these tables.

i GDA Gateway Servers 5% - O

.. S0A Gateway Server Configuration - Local Server &3

rtn

+5 f* 7 || webServices | Dataviews / XDs / X5Ls |
Name | M... | ASy | Mod | Driver | WebService | DataSource Id | Data¥iew |
AlLX Server Y ™ _| MySQL Driver accountsmovements odbeD: isarisBank, tablef count: 5 account: 5 !
DMZ Y ~
dublin dey ¥ wigsct MySQL Driver audit odbcD: isarisBank, L dil audit
jk server ¥ My A MySOQL Driver branch odbcDsn=RisarisBank, tableName =branch branch
jk server linux Y ™ 5 .
AETT ¥ Wiy MyS0OL Driver currentaccount odbcDsn=RisarisBank, tableName =currentaccount currentaccount
> Local Server ¥ My th MySOL Driver customeraccountxref odbcDsn=RisarisBank, tableName =customeraccountxref customeraccountxref
Isibre server Y ™
PCRIWS ¥ wysct MySQL Driver customerinformation odbcDsn=RisarisBank, tableName =customerinformation customerinformation
risaris.com server ¥ Wiy D MyS0OL Driver depositaccount odbcD: isarisBank, L depositaccount depositaccount
vse Y \
2705 Server v et MySQL Driver tellertable odbcDsn=RisarisBank, tableName =tellertable tellertable
z/wse Y
, .
You’' ve ust created 8 Web Services from your

4.2 Accessing the WSDL
Web Service Description Language (WSDL) is a standard, XML-based language that is used to

describe a Web Service.
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For each of the 8 web services you’ ve created
you with a WSDL to describe the Web Service. The WSDL itself is usually interpreted by a web
service client, but it is useful to know where to find the WSDL for each of your Web Services.

As WSDL is XML-based, it will open in your browser of choice. To see the WSDL for one of your
Risaris Bank web services, do the following in your SOA Gateway Control Centre:

9 Click on the web service you are interested in, for example the branch service.

9 The properties for this web service should appear in your Properties View. If you do not
see the Properties view, select Window -> Show View -> Other -> General -> Properties
and click OK.

9 Inthe properties view, there is a link to your WSDL. Click it to open the WSDL in a
browser.

... SDA Gateway Server Configuration - Local Server 3

WebServices | Data¥iews / X5Ds / %5Ls |

Mod | Driver | WebService | DataSource Id
A ;:\'- MySQL Driver accountsmovements odbcDsn=RisarisBank, tableM;
Myt ;.j\'- MySOL Driver audit odbcDsn=RisarisBank, tableN;
! ;.:\'- MySOL Driver branch odbcDsn=RisarisBank, tableM;
My ;.j\'- MyS0L Driver currentaccount odbcDsn=RisarisBank, tableN;
Miy: ;-j\'- MySQL Driver customeraccountxrel odbcDsn=RisarisBank, tableNi
A ;:\'- MySQL Driver customerinformation odbcDsn=RisarisBank, tableM;
Myt ;.j\'- MySOL Driver depositaccount odbcDsn=RisarisBank, tableN;
! ;.:\'- MySOL Driver tellertable odbcDsn=RisarisBank, tableN;

.. SOA Gateway Action Log 23

| Server name | Message
iiLocal Server ODBC discovery completed, & WebService(s) generated
i Local Server Configuration autosaved due to published WebService modification{s)

L e I —— [Py P BN g By |

El Properties 3

webService properties
]

e  WebSer “ties

MName )

Data¥iew IErt. j
Driver IMySQ; | SBCS-Codepage I
Read-only [] MBCS-Codepage I

WSDL URL is . http:/ flocalhost:56000,/branch®WsDL

« WebService Identification and options

odbcDsn IRisarisBank
schemaMame I
tableName Ibranch
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http://www.risaris.com/documentation/v241/admin/cctop.htm

You can view the WSDL for the other web services by clicking the link from their properties
view.

This WSDL is the starting point for using Web Services, and can be used time and again by
different web service clients.

5 Creating BPMS Process

The BPMS process to use is available in the appendix. Download this file to your system.

Select File -> Import -> Existing Projects Into Workspace -> Select Archive File and select the ZIP file
that you’'ve downl oaded.

The process will be imported into your workspace.

The Forms folder contains 2 forms for use with this process. The SelectNames.xform will allow the
user to enter a Customer ID. This will call the SOA Gateway web service to return all the customers
with that ID. The DisplayCustomers.xform will display the details for each customer found.

The WSDLs directory contains references to the WSDLs that you created earlier.
The SoaGatewayTutorial.bpm is the Business Process Diagram for this process.

The QueryResultstoFormlList.xsl is an XSL stylesheet which transforms the results returned from the
SOA Gateway web service into a structure that fits into the DisplayCustomers XForm.

5.1 Process Walkthrough

The following section outlines how the process works.

The process starts with the SelectNames.xform as a BPEL4People People Initiating Process Activity

(PIPA) BPEL4People task. The processwi | | continue to t hteenthapsithet Cust o
output from the XForm to the input of the SOA Gateway Customerinfomation web service.

The "“Display Customers”™ task wil!/l use the QuerytF
Gateway response to the DisplayCustomers XForm input. To do this, a BPEL method called

“doXsl Transform()” is wused.

The DisplayCustomers XForm is a BPELAPeople People Activity task.

Al | BPEL4People tasks aYeanptloylke"uged ewi th the *“ €
The “ Rewiaesw UWdioets'n’t do anyting in the process, |

the processing the selected customer. For example, it could be used to call another web service
which returns the account details for this person.
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5.2 Process Execution
Verif y that the Userid and password used in the “L

password required to access your MySQL Table.
Deploy your SoaGatewayBPMSTutorial to the BPMS Server.

Login to the UI-FW (http://localhost:8080/ui-fw) as the employee role, which is usually
“ e x argpd eist h”

Under the Processes tab, you should see a proces
Click this, and enter the asterisk symbol (*) as the Customer Number. Click“ St ar t Process” |
call the SOA Gateway web service and return all customers.

A list of customers is returned:

¥ Intalio | Workflow - Mozilla Firefox

File Edit Wew History Bookmarks Tools Help

<E| - - @ ﬁ & http:/ /localhost:8080,/ui-fw tasks.htm

I (T
|_| http://localhos...nformation?WSDL | I Intalio | Workflow Q S‘I Geronimo Console Login %)

WINTALIO

Tasks Notifications | Processes

|Description Creation Date/Time

|Please click here for the Tutorial Process. ThuJun 12 14:06:38 BST 2008
CID First Hame Surname Address1 Address2 City PostCode i’

1 e Ak Mansfield MAS 98]

et WS 34 Green Street Crozses Strest
2 . Manchester MAT 4428
Peter Richardson ‘West Gate Avenue Frankfield
=
Click “Complete” to finish the process.

6 Troubleshooting

6.1 Troubleshooting Process Execution

1 Use the BPMS console to view the stage that your process is in, and any potential error

messages.
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http://localhost:8080/ui-fw

9 See the Geronimo window to view possible error messages.
9 Verify that the user id and password provided in List Customers task matches the user and
pass required to access your MySQL database.
9 Verify that the end point in the WSDL is correct. You can do this by right-clicking the
WSDLs/ customerinfomation. wsdl file and sel ect

7 Conclusion
This tutorial shows how to access MySQL from Intalio BPMS using the SOA Gateway.

8 Appendix

Click here for SoaGatewayBPMSTutorial.zip
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http://www.risaris.com/tutorials/mysqlviaintalio/SoaGatewayBPMSTutorial.zip

