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1. Introduction 
In this tutorial we will show you how to build a Visual Basic application to access MySQL via the SOA 

Gateway.  

2. Prerequisites 
It is assumed that you are running the 3 components, MySQL, Visual Basic and the SOA Gateway on 

Windows.  

It is assumed you already have a SOA Gateway server and Control Centre installed. See here for 

more info about installing the SOA Gateway. 

3. Setup 
To build and run Visual Basic applications, you will need a Visual Studio IDE. If you do not already 

have it installed, we recommend using the Microsoft Visual Studio Express range of products. They 

can be downloaded freely from Microsoft website, packaged for a number of languages. See here for 

more information about downloading, installing, and configuring Visual Basic Express.  

You will also need a MySQL database. Again, the Open Source version (known as the MySQL 

Community Server) can be freely downloaded from the MySQL website. See this link for download, 

and here to step you through the installation and configuration. 

3.1. Populate MySQL Database 
Now that you’ve got MySQL installed and configured, you will need to populate it with some 

demo data. For this we use the RisarisBank sample. This is available here . 

Save this file to “C:\Temp\RisarisBank.sql” 

 Connect to the MySQL Server using the mysql command.  

E.g shell> mysql –u root –p  

This command connects to the server using the MySQL root account to make sure that 

you'll have permission to create the RisarisBank database. The -p option tells mysql 

to prompt you for the root password. Enter the password when prompted. (Remember 

that the MySQL root account is not the same as the operating system root account 

and probably will have a different password.) 

 Create the RisarisBank database.  

mysql> CREATE DATABASE RisarisBank; 

mysql> use RisarisBank; 

 Load the contents of RisarisBank.sql into the RisarisBank database. E.g. 

mysql> SOURCE c:\Temp\RisarisBank.sql 

http://www.risaris.com/documentation/v411/installation/index.htm
http://www.microsoft.com/express/vb/
http://dev.mysql.com/downloads/mysql/5.0.html#downloads
http://dev.mysql.com/doc/refman/5.0/en/windows-installation.html
http://risaris.com/samples/RisarisBank.sql
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 After the SOURCE command finishes, you can view your new tables.  

mysql> SHOW TABLES; 

mysql> DESCRIBE CustomerInformation; 

mysql> DESCRIBE Branch; 

etc … 

3.2. Set up ODBC Access 
The final thing to do with your MySQL Database is to set up an ODBC DSN which will be used by 

the SOA Gateway to access this database.  

Click Start, Control Panel, Administrative Tools, Data Sources (ODBC) 

From the resulting screen, choose the “System DSN” Tab. 

Click Add 

From the list of data source drivers, select “MySQL ODBC 3.51 Driver”.  

If you do not see this driver in the list, you need to install the MySQL Connector. See here for 

more information. We recommend installing v3.51. 

Click Finish, and a window will appear allowing you to enter the DSN information. Add the 

following: 

Data Source Name: RisarisBank 

Description: The Risaris Bank Sample in MySQL 

Server: localhost 

User: root 

Password:  *** your MySQL root password *** 

Database:  RisarisBank (select from the drop down list) 

http://www.mysql.com/products/connector/odbc/
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All other options can be left as-is. Click OK.  

4. Discovery 
At this stage you’ve got a Visual Basic IDE, and a MySQL database with some sample data in it. In this 

section we’ll show you how to create web services from each of the MySQL tables. These web 

services can be used by the Visual Basic language (and many others) to give you direct real-time 

access to your MySQL Data.  

4.1. Web Service Creation using SOA Gateway 
Start your SOA Gateway Control Centre. See here for an introduction to the Control Centre. 

In your servers view, right click the entry which represents your local SOA Gateway Server. Select 

“Create New Web Services”.  

http://www.risaris.com/documentation/v411/gettingstarted/intro.htm
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From the next dialog, choose “MySQL Driver”. If you do not see have a MySQL Driver in the list, 

see how to create one here. 

 

Click Next. 

The next screen gives you the ability to add information about your DSN 

http://www.risaris.com/documentation/v411/admin/ccserver.htm#mod_drivers
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Enter the above information and click Discover. 

The wizard will display all the tables it finds at this (RisarisBank) DSN.  

Click “Select All”, and click “Import”.  

The wizard will create web services from each one of these tables. 

 

 

 

You’ve just created 8 Web Services from your 8 MySQL Tables! 

 

4.2. Accessing the WSDL 
Web Service Description Language (WSDL) is a standard, XML-based language that is used to 

describe a Web Service.  

For each of the 8 web services you’ve created in the previous section, the SOA Gateway provides 

you with a WSDL to describe the Web Service.  The WSDL itself is usually interpreted by a web 
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service client, such as Visual Basic, but it is useful to know where to find the WSDL for each of 

your Web Services.  

As WSDL is XML-based, it will open in your browser of choice. To see the WSDL for one of your 

Risaris Bank web services, do the following in your SOA Gateway Control Centre: 

 Click on the web service you are interested in, for example the branch service. 

 The properties for this web service should appear in your Properties View. If you do not 

see the Properties view, select Window -> Show View -> Other -> General -> Properties 

and click OK. 

 In the properties view, there is a link to your WSDL. Click it to open the WSDL in a 

browser. 

 

 
 

http://www.risaris.com/documentation/v241/admin/cctop.htm
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You can view the WSDL for the other web services by clicking the link from their properties 

view.  

This WSDL is the starting point for using Web Services, and can be used time and again by 

different web service clients.  

 

5. Accessing Web Service with Visual Basic 
We will use Visual Basic to build an application which accesses our new Risaris Bank Web Services via 

the WSDL.  

5.1. Initial Setup 
Start Microsoft Visual Basic Express and create a New Windows Forms Application Project 

named Risaris Bank Demo. 

 

 

In the Solution Explorer, right click the solution name, then Add Web Reference (VC # 2005) or 

select Add Service Reference (VC# 2008) 
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Figure 1: VB 2005 

 

 

Figure 2: VB 2008 
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We want to use 2 of the Web Services we’ve created, the customerinformation and the 

currentaccount web services.  

 Copy the URL of your web service WSDL into the URL box e.g. 

http://localhost:56000/customerinformation?WSDL 

 Click Go.  

 Once the WSDL has been loaded, change Web Reference / Namespace to 

CustomerInformation 

 Click Add Reference / OK 

 

 

Figure 3: VB 2005 
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Figure 4: VB 2008 

 

Do the same for the currentaccount WSDL, http://localhost:56000/currentaccount?WSDL, 

except change the Namespace to CurrentAccount 

N.B. Obviously, depending on your particular setup, localhost:56000, may have to change 

appropriately. 
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You should now have 2 new Service / Web References loaded into your Solution Explorer 
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5.2. Designing the Form 
In this section we’ll add the necessary controls to our Form. Before you start ensure, that you 

are in the Designer View (View -> Designer), and that you have the control Toolbox available 

(View->Toolbox) 

 

 

I’ve used the following controls in this Form 

 GroupBox  with Text property set to Customer Information. 

 GroupBox  with Text property set to Account Information. 

 Label (Customer Number, Current Account Balance, Current Account Overdraft). 

 TextBox 1 (Customer Number). 

 TextBox 2 (Current Account Balance).  

 TextBox 3 (Current Account Overdraft). 

 Button 1 (Text property set to Search) 

 Button 2 (Text property set to Get Account Details) 

 ListView1 (MultiSelect property set to False). 

The ListView is the only control that needs additional setup. 

When you add this control, right-click on it and select Edit Column from the pop-up menu.  Add 

8 members, each with the following Text property as this is the order of the columns passed 

back by the web service. 

 Customer Number 

 First Name 

 Surname 

 Address Line 1 
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 Address Line 2 

 City 

 Post Code 

 DOB 

 

 

Note that I haven’t changed any of the default design names that the VB designer has given me.  

You may change these to whatever you wish, but be aware your code in the next section will 

have to be cognisant of this! 
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5.3 Writing the Code 
Now that the Form controls have been added, we need to write the code to call our Web 

Services when the buttons are clicked. 

The entire code for Form1.vb is listed in the Appendix. 

Switch to your Code view, by clicking View->Code 

General Declarations 

In the General Declarations section at the top of the form add the following: 

Imports Risaris_Bank_Demo.CustomerInformation 

Imports Risaris_Bank_Demo.CurrentAccount 

 
These statements include your 2 Web References you added earlier. 

Button1_Click 

Switch back to your Designer view, and double-click the “Search” button in your Form. Your IDE 

will switch over to the code view, and a new member function, Button1_Click, to handle the 

button click will be created. 

When this button is clicked, we want to take the contents of TextBox1 (which is the Customer 

ID), and send this to our Customer Information web service. The web service should return the 

required customer information for that ID.  

We break that customer information down into its respective parts, and then add that to our 

listView.  

N.B. Please note the security values for username and password, which in our case, are root and 

“” respectively. Change to those for your MySQL . 

The code is as follows: 

 

VB 2005 Code 

 

Dim customerInfoSecurity As Risaris_Bank_Demo.CustomerInformation.Security 

        customerInfoSecurity = New 

Risaris_Bank_Demo.CustomerInformation.Security() 

        customerInfoSecurity.UsernameToken = New 

CustomerInformation.SecurityUsernameToken() 

        customerInfoSecurity.UsernameToken.Username = "root" 

        customerInfoSecurity.UsernameToken.Password = "" 

 

        Dim service As customerinformationRootService 

        service = New customerinformationRootService() 

 

        ' create a new key value that we send to the web service 

        Dim key As 

Risaris_Bank_Demo.CustomerInformation.customerinformationGroupKeyType 

        key = New 

Risaris_Bank_Demo.CustomerInformation.customerinformationGroupKeyType 

        ' set the CustomerNumber to the contents of textBox1 
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        key.CustomerNumber = TextBox1.Text 

 

        ' set up a variable to store the result 

        Dim results As 

Risaris_Bank_Demo.CustomerInformation.customerinformationRootElementType 

 

        ' call the "list" operation of web service! 

        results = service.list(key) 

        ListView1.Items.Clear() 

        Dim customer As customerinformationGroupType 

        For Each customer In results.customerinformationRoot() 

            Dim lv As ListViewItem 

            lv = New ListViewItem(customer.CustomerNumber) 

 

            ' add the rest of the items in the row 

            lv.SubItems.Add(customer.FirstName) 

            lv.SubItems.Add(customer.Surname) 

            lv.SubItems.Add(customer.AddressLine1) 

            lv.SubItems.Add(customer.AddressLine2) 

            lv.SubItems.Add(customer.City) 

            lv.SubItems.Add(customer.Postcode) 

            lv.SubItems.Add(customer.DateOfBirth) 

 

            ' add the row to the listView 

            ListView1.Items.Add(lv) 

            ListView1.View = View.Details 

            ListView1.FullRowSelect = True 

        Next 

 

VB 2008 Code 

 

        Dim customerInfoSecurity As 

Risaris_Bank_Demo.CustomerInformation.Security 

        customerInfoSecurity = New 

Risaris_Bank_Demo.CustomerInformation.Security() 

        customerInfoSecurity.UsernameToken = New 

CustomerInformation.SecurityUsernameToken() 

        customerInfoSecurity.UsernameToken.Username = "root" 

        customerInfoSecurity.UsernameToken.Password = "" 

 

        Dim service As 

CustomerInformation.customerinformationRootPortTypeClient 

        service = New 

CustomerInformation.customerinformationRootPortTypeClient() 

 

        ' create a new key value that we send to the web service 

        Dim key As 

Risaris_Bank_Demo.CustomerInformation.customerinformationGroupKeyType 

        key = New 

Risaris_Bank_Demo.CustomerInformation.customerinformationGroupKeyType 

        ' set the CustomerNumber to the contents of textBox1 

        key.CustomerNumber = TextBox1.Text 

 

        ' set up a variable to store the result 

        Dim results As 

Risaris_Bank_Demo.CustomerInformation.customerinformationRootElementType 

 

        ' call the "list" operation of web service! 
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        results = service.list(customerInfoSecurity, Nothing, key) 

        ListView1.Items.Clear() 

        For Each customerinformationGroupType In 

results.customerinformationRoot() 

            Dim lv As ListViewItem 

            lv = New 

ListViewItem(customerinformationGroupType.CustomerNumber) 

 

            ' add the rest of the items in the row 

            lv.SubItems.Add(customerinformationGroupType.FirstName) 

            lv.SubItems.Add(customerinformationGroupType.Surname) 

            lv.SubItems.Add(customerinformationGroupType.AddressLine1) 

            lv.SubItems.Add(customerinformationGroupType.AddressLine2) 

            lv.SubItems.Add(customerinformationGroupType.City) 

            lv.SubItems.Add(customerinformationGroupType.Postcode) 

            lv.SubItems.Add(customerinformationGroupType.DateOfBirth) 

 

            ' add the row to the listView 

            ListView1.Items.Add(lv) 

            ListView1.View = View.Details 

            ListView1.FullRowSelect = True 

        Next 

 

Button2_Click 

Switch back to Design view and double-click on the Get Account Details button which will add 

the Button2_Click handler. Within this subroutine we will call the current account web service. 

Set up security details. Call the service with customer number as key. 

 

VB 2005 Code 

 

If ListView1.SelectedIndices.Count = 1 Then 

            ' create a new instance of the CurrentAccount web service 

            Dim currentAccountSecurity As 

Risaris_Bank_Demo.CurrentAccount.Security 

            currentAccountSecurity = New 

Risaris_Bank_Demo.CurrentAccount.Security() 

            currentAccountSecurity.UsernameToken = New 

CurrentAccount.SecurityUsernameToken() 

            currentAccountSecurity.UsernameToken.Username = "root" 

            currentAccountSecurity.UsernameToken.Password = "" 

            Dim currentAccountService As New currentaccountRootService() 

 

            Dim currentCustomerId As String 

            ' get the currrently selected Customer ID 

            currentCustomerId = 

ListView1.SelectedItems.Item(0).SubItems.Item(0).Text 

            ' create a new key value that we send to the web service 

            Dim key As 

Risaris_Bank_Demo.CurrentAccount.currentaccountGroupKeyType 

            key = New 

Risaris_Bank_Demo.CurrentAccount.currentaccountGroupKeyType 

 

            key.AccountNumber = "" 

            key.CustomerNumber = currentCustomerId.ToString 
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            ' set up a variable to store the result 

            Dim results As 

Risaris_Bank_Demo.CurrentAccount.currentaccountRootElementType 

 

            ' call the "list" operation of web service! 

            results = currentAccountService.list(key) 

 

            ' Now put the results of the web service  

            ' into the Balance and Overdraft text boxes 

            TextBox2.Text = 

FormatCurrency(results.currentaccountRoot(0).Balance / 100, 2) 

            TextBox3.Text = 

FormatCurrency(results.currentaccountRoot(0).OverdraftLimit / 100, ) 

        End If 

 

VB 2008 Code 

 

        If ListView1.SelectedIndices.Count = 1 Then 

            ' create a new instance of the CurrentAccount web service 

            Dim currentAccountSecurity As 

Risaris_Bank_Demo.CurrentAccount.Security 

            currentAccountSecurity = New 

Risaris_Bank_Demo.CurrentAccount.Security() 

            currentAccountSecurity.UsernameToken = New 

CurrentAccount.SecurityUsernameToken() 

            currentAccountSecurity.UsernameToken.Username = "root" 

            currentAccountSecurity.UsernameToken.Password = "" 

            Dim currentAccountService As 

CurrentAccount.currentaccountRootPortTypeClient 

            currentAccountService = New 

CurrentAccount.currentaccountRootPortTypeClient() 

 

            Dim currentCustomerId As String 

            ' get the currrently selected Customer ID 

            currentCustomerId = 

ListView1.SelectedItems.Item(0).SubItems.Item(0).Text 

            ' create a new key value that we send to the web service 

            Dim key As 

Risaris_Bank_Demo.CurrentAccount.currentaccountGroupKeyType 

            key = New 

Risaris_Bank_Demo.CurrentAccount.currentaccountGroupKeyType 

 

            key.AccountNumber = "" 

            key.CustomerNumber = currentCustomerId.ToString 

 

            ' set up a variable to store the result 

            Dim results As 

Risaris_Bank_Demo.CurrentAccount.currentaccountRootElementType 

 

            ' call the "list" operation of web service! 

            results = currentAccountService.list(currentAccountSecurity, 

Nothing, key) 

 

            ' Now put the results of the web service  

            ' into the Balance and Overdraft text boxes 

            TextBox2.Text = 

FormatCurrency(results.currentaccountRoot(0).Balance / 100, 2) 
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            TextBox3.Text = 

FormatCurrency(results.currentaccountRoot(0).OverdraftLimit / 100, ) 

        End If 

 

5.4 Running the code 
By hitting F5 or Debug -> Start Debugging, you can run your code. In the Customer Number text 

box, you may enter * or a known customer number and hit the Search button to call the 

Customer Information web service and get a list of all the customers in the CustomerInformation 

table.  

 

From the resultant list, select the record you are interested in. Then click on the Get Account 

Details button which will call the CurrentAccount web service to retrieve the current account 

balance and overdraft limit for this customer.  Example show results for Customer Number 4: 
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If you hit problems, you may wish to debug your code by adding breakpoints in your code. See 

the IDE documentation for further information.  

 

6. Conclusion 
This tutorial shows how to access MySQL from Visual Basic using the SOA Gateway. As you can see, 

you have built a powerful application that uses Web Services to retrieve information in real-time. 

 

7. Appendix 

Form1.vb for VB 2005 
 

Code available here 

 

Form1.vb for VB 2008 
 
Code available here 

http://www.risaris.com/tutorials/mysqlviavb/Form1_2005.vb
http://www.risaris.com/tutorials/mysqlviavb/Form1_2008.vb

